General >> General JK and MotS Discussion >> JK crashing...     (Moderator: Admins) Previous Topic | Next Topic
Page 1 of 1
 Author 
 Post 
Post 16-Aug-2007 02:07        

Can someone help me?

When ever i set my JK to enable 3D Acceleration and try to play i get a black screen with a Microsoft error report

this really sucks specially since now i cant really play MP unless i play [ugly] 8 bit texture

can someone help me with this problem?

ive already tried reinstalling and compadibility mode

all shot to hell
Post 16-Aug-2007 15:49        

After you enable 3d Acceleration, make sure you set your resolution setting back to what you want it at (JK/MotS will auto-select 320x200 in the list, and it has some "modex" setting note thing next to it -- I get issues, like crashing, when I play with one of the "Modex" resolutions)
Post 16-Aug-2007 23:47        

i did.... Neutral
Post 24-Nov-2007 04:01        

Having the very same problem. I've tried different resolutions, but any time I enable 3D Acceleration, the game crashes as soon as I leave the option screen.

Been doing some searches, they basically lead me here, any help would be great.
Post 05-Apr-2008 01:02        

I had a similar problem when I installed the game again the other day. I might not be much help, but I played it fine with 3d acceleration (minus that dithering problem) but when I went to play again it would crash after loading any level. It seemed to run ok in software, but I couldn't get 3d acceleration to work again.

I'm not sure exactly what was happening. I reinstalled and its worked fine ever since, despite changing 3d settings fairly often.
Post 19-Feb-2009 23:24        

I also am experiencing the same crashing issues. Every time I play or run Jedi Knight with 3D acceleration enabled, it crashes and gets or goes to a black screen with a Microsoft error report with music still playing from the CD. Jedi Knight will also crash randomly at some point sometimes by just going through the different menu settings. I am convinced that it must be the latest newest Catalyst Drivers and not a hardware malfunction because the crash happens on both a Radeon x850 XT Platinum AGP and a Radeon 9800 Pro 256 mb. I've also tried checking, swapping, and changing DDR RAM types/brand from PC3200 to PC2700 with all the correct latest BIOS settings intact as well. I have also never overclocked anything - nothing is overheating either case is properly ventilated.
I am also aware of legacy games such as Jedi Knight no longer running properly with new PCI express Radeon HD video cards ( such as no support for 16 bit dithering ? ).

Windows XP Professional with SP 3
PC Chips M848A 5.0 motherboard
AMD Athlon XP 3000+ 2.167 Ghz
2 GB PC3200 Mushkin RAM / or 2 GB PC2700 Patriot RAM
All latest software & OS updates patches etc.
Post 02-Jul-2009 00:19        

This may have been resolved elsewhere, but just in case readers havent found solution yet.

IF your JK crashes, due to the 3d Acceleration option, try this...

-Load JK, as soon as you get the option SETUP click that, uncheck 3d-Acceleration box.
-Change resolution to 640 x 480, click OK.
-Load a Multiplayer level ( like BGJ ) in this poor quality mode.
-Test your normal abilities in this mode ( run around, shoot your gun, saber on/off, etc)
-After 10 seconds of testing, press Escape, SETUP, check box FOR 3d-acceleration, change resolution to 640 x 480 ( same resolution as before ). Go back to game.

Many times, this resolves the problem
( this has to be done each time you close and reopen JK: uncheck, load, play-test, check, play )

For me, the problem was due to an update in NVidia video graphix card ( 6600GT ), which i believe they are still resolving, and making slow progress on.

Hope that helps some of you.
-Pali
Post 10-Nov-2009 19:34        

The ddraw patch on the jkhub front page fixes this in XP now. Doesn't work in Vista / win7 though, at least, not the 64 bit versions.

*update*: If I use the ddraw.dll in win7 x64, along with the -windowgui command line option (that is: jk -windowgui), it works fine.

The high-res texture pack looks great now, too!
*** Post commands are unavailable for guests. ***