General >> General JK and MotS Discussion >> JKDF2/JKMOTS w/ Windows 8?     (Moderator: Admins) Previous Topic | Next Topic
Page 1 of 1
 Author 
 Post 
Post 10-Jul-2013 08:32        

I've been away for a bit--from both these games & Windows--so please excuse what may be a silly question, but is it possible to play JKDF2 &/or JKMOTS with Windows 8 (64-bit)? I realize that I can dual-boot with Windows XP or 7 & run it but I rather enjoy much about Windows 8 & want to continue using it. I'm guessing that even if it's possible, some sort of compatibility mode would be required, due to it being 64-bit, etc.
naU
Post 30-Sep-2013 06:21        

lol, in case you're still curious, yes. Both JKE and JK work rather well on Windows 8, despite being a complete PITA to get running.
Post 18-Dec-2013 14:59        

Sorry to bother you guys but I'm new here, and I've been hunting around for a solution to my problem but so far no luck. I'm currently running Windows 8.1 and just cannot get Jedi Knight of Mysteries of the Sith running with the 3d acceleration.

My problem is that the games load through menus and movies fine, but when I get to the game itself, the game either crashes, or with the acceleration fix, loads but the graphics are missing. just get a black screen with the games hud still visible and sound effects playing but nothing else.

My copies of the games are from steam and I'm running a Geforce GTI 670. So far I've tried the ddraw patch on the front page of this sight and I've created a batch file that kills the windows explorer. I've tried 16 bit colour mode, and I've tried the -windowsgui command. I've deleted the launcher files and am running directly from the executables and I've tried every combination of compatibility settings I can think of. Nothing works and I still get the same results.

The games do work in software mode, but the weapons animate so fast that when I swing the lightsaber I just hear the sound effect and watch stormtroopers drop dead. The weapon itself barely twitches.

Thanks for you help and apologies if a solution has been presented else where. I've searched high and low but can't seem to find one.
Post 01-Jan-2014 23:17        

One thing to note: There's no need to use -windowgui in Windows 8. The menu and cutscenes display just fine! Windows 8 doesn't have color issues with paletted games.


Sorry to say but there seems to be no way to get the D3D mode working. Maybe someone will have a solution someday, but until then Software mode isn't too bad (again, since Windows 8 doesn't have color issues like 7)

You can limit the framerate using a ddraw.dll from http://bitpatch.com/ddwrapper.html (This will also work for the D3D mode if that ever gets fixed later, I tested it in Win7)

Turn on FakeVsync and set FakeVsyncInterval to 34 to limit the game's framerate to 30. For some reason Jedi Knight will keep the game's framerate at 30 if you run any higher, but then the weapons will start to animate too fast. So 30 is the ideal framerate.

You need 'Backbuffer in System Memory' off in-game for it to work.


If it runs too slow (around 20fps) then you can fix it by editing the registry.

1) Run regedit.exe
2) Go to HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/AppCompatFlags/Layers
3) You should see an entry for JK.EXE. Double click it to edit it.
4) Replace the entry currently in it with
$ DWM8And16BitMitigation 8And16BitTimedPriSync 8And16BitAggregateBlts Layer_ForceDirectDrawEmulation


Some explanations:
Layer_ForceDirectDrawEmulation: Uses software emulation instead of hardware emulation (Windows 8's default) which of course doesn't work well with the software mode (or at all...). Additionally this also prevents the Charms menu from showing when in-game.
8And16BitTimedPriSync: Menu items will vanish and cause strange artifacts in the menu without this when DirectDraw emulation is on.
8And16BitAggregateBlts: Game will flicker black without this when DirectDraw emulation is on.
DWM8And16BitMitigation: Windows will add this permanently if you run JK with a compatibility mode. This is what prevents the "need 256 colors" error.


Note that this will disable the option to use Hardware Acceleration, so if a fix for it DOES appear in the future, you'll have to open this key again and remove the "Layer_ForceDirectDrawEmulation" flag.
*** Post commands are unavailable for guests. ***