General >> General JK and MotS Discussion >> How to run Jk in win7     (Moderator: Admins) Previous Topic | Next Topic
Page 1 of 2 Goto page 1, 2  Next
Post 09-May-2015 17:29        

I always played Jk in winxp, but now i have the Windows 7 and i wanted to play, but when i run the JEDI.exe (autorun) and click on install its give me a message saying that i have to run the SETUP.exe direct by the jk disk. I do exactly what they say but the setup program don't open. I use Windows 7 ultimate 32bits.
Post 16-May-2015 18:20        

Try copying the content of the CDs to a folder of your choosing. Make a folder somewhere (and call it something like JK), copy the folders CONTROLS, EPISODE and RESOURCE into your JK folder (this includes the first set of videos). Go into the EXE folder and copy the content to your JK folder. That should be ALL you need. If you want all videos copy the RESOURCE/VIDEO folder from the second disc.

Next up is to install the latest unofficial patch.

After that, run the game with JK.EXE

Hope this helps.
Post 17-May-2015 17:55        

finally someone answered. I'll test as soon as I have time , thank you.
Post 24-May-2015 03:08        

I've tried and it's says that JK.exe is not a valid win32 file, and when i open jk.exe without the unofficial patch it's says it can't load the file(and apears somo wierd letters)
Post 24-May-2015 10:59        

It should work fine. Have you tried JK Launcher (found here on the hub). Also, I use a bat file to launch JK. Copy the following into a text file and then save it as a .bat file (save as all files and put the entire file name and extension in quatioations, ie "runjk.bat"):

cd "C:\Program Files (x86)\LucasArts\Jedi Knight\"
jk.exe -windowgui
Post 24-May-2015 14:14        

hey, i installed jk launcher, and whenn i going to install the game i click in the install button and nothing happens , and the other way with the bat file, when i rename the file to runjk.bat, nothing happens and i keep getting errors
Post 25-May-2015 01:59        

So you haven't installed it yet? Make sure you right-click on the setup file and select Run As Administrator.

You may have to do a manual installation:
Post 30-May-2015 14:29        

thanks for all who helped me, on the end i've discover that the gog version (for what i figured) can initiate the mods with the jklauncher, but I have another doubt, the jk enhanced needs the jk unofficial patch, and when i click check for update on the jklauncher the program finds the unofficial patch but it's don't installs it(i click in install last patch but the following message appears "Failed to install latest patch")

Sorry for my bad inglish
Post 04-Jun-2015 00:15        

Hello again! i've managed to install the unofficial patch, but this time the mod does not work, i've installed the mod by the jklauncher but nothing happens, and i have some other problems, like the "advanced display options" does not appear in the menu!

Sorry for my bad english!!!
Post 04-Jun-2015 02:03        

This is a bug in the latest version of JK Launcher. You need to create a folder called "Mod" in the JK directory. Copy the JKE.gob file to that directory.
Post 04-Jun-2015 12:34        

Hello the jk launcher have created this folder and JKE.gob is into the folder, but the mod do not work and for some reason the unofficial patch uninstall it alone and don't want to install again!!!
Post 04-Jun-2015 12:44        

The unofficial patch is required to run JKE. Just make sure to follow the instructions exactly (including making a backup of the JK.exe file).
Post 04-Jun-2015 15:30        

I've tried to install the patch by myself but the game don't work
Post 05-Jun-2015 14:24        

Need more information than that. You might need to start over and reinstall the game then apply the patch. Post back exact error messages that you get afterwards so that we can troubleshoot further.
Post 05-Jun-2015 20:25        

well, the messages i got with jklauncher is "Failed to install latest patch" but i gona try to re install the game and install the patch Question
*** Post commands are unavailable for guests. ***